TL Tales: Being Bold (and the GGN)
tech Tech · TL · GGN · Network · OpenConfigHow do TLs know what to do – and what have I been working on at Google?
The Right-Sized Tool: Building Software with 100% AI
tech Tech · AI · LLMAn experiment in building a highly specific cycling data analysis tool without writing a single line of code myself.
Gluten-Free, Dairy-Free, Low FODMAP Biryiani
personal foodA recipe for biriyani, modified for those with dietary restrictions.
v3 Gallery
personal PhotographyUpdating the gallery on this site has been an on-again off-again project for a long time. Mainly because I was running in to some issues with Expose. This version is built as a project from the ground up: exercising my rusty front-end “skills” and seeing how some of the Gemini tooling can help with such projects.
The new gallery is at p.rob.sh/v3.
NANOG 90: Pondering Abstractions
tech Tech · OpenConfig · YANGI had the pleasure of giving the keynote presentation at NANOG90 - sharing some thoughts and lessons that we have learnt in the 10 years since we started the OpenConfig project.
This was a really enjoyable presentation to put together and give. It balanced being able to look back at what we’ve learnt, and also think about some important lessons that I wanted to share with the networking community.
Lessons from Career Coaching
personal workIn the autumn of 2022, I got an opportunity to attend an external leadership course. One of the things that it involved was some coaching sessions. I didn’t really think that talking to someone about work was something that I needed (and honestly probably didn’t understand what a coach did…), but engaged with it anyway.
Cue the start of 2023 — Google went through some big changes, and unfortunately, my health took another downturn. At the same time, I was personally struggling with balancing the work that I was doing leading a wider technical team (especially with layoffs impacting their direct management), driving an innovation project (which I was mostly doing out of hours), and keeping myself healthy.
Published IETF RFCs
tech Tech · IETFOver the years I have published a number of RFCs in the IETF. They are listed below.
As primary author:
- RFC7684 - OSPFv2 Prefix/Link Attribute Advertisement
- RFC7777 - Advertising Node Administrative Tags in OSPF
- RFC7855 - Source Packet Routing in Networking (SPRING) Problem Statement and Requirements
- RFC8355 - Resiliency Use Cases in Source Packet Routing in Networking (SPRING) Networks
- RFC8370 - Techniques to Improve the Scalability of RSVP-TE Deployments
- RFC8402 - Segment Routing Architecture
- RFC8660 - Segment Routing with the MPLS Data Plane
- RFC8662 - Entropy Label for Source Packet Routing in Networking (SPRING) Tunnels
- RFC8665 - OSPF Extensions for Segment Routing
As contributor:
SailGP San Francisco
personal Photography
SailGP's event on the San Francisco Bay, May 2023
Reimagining Network Devices
tech OpenConfig · Tech · YANGAlmost 10 years ago, there was a shift in the IP networking industry. The move towards SDN, and its adoption by hyperscalers as a means to break apart traditional network architectures had set the scene for disruption. The question of “how are we using SDN?” was on the lips of vendor and telco executives — and lead to many initiatives in the industry - both those that can be thought of “SDN” and those that were more incremental.
Big Pine Lakes
personal PhotographyWe spent a few days in the High Sierra, off the grid, hiking the Big Pine Lakes trails. Highly recommended.
I uploaded a gallery of some photography from that trip, including a few taken as we passed through Yosemite.
The gallery can be found here.
Older » Post Index


